Bloquear publicidad en Youtube – Mikrotik

por | 11/11/2018

Ya hace un tiempo compre un router Mikrotik que utilizo para interconectar las diferentes redes que tengo en casa ( si si… tengo más de una red en casa ) y también cumple tareas de firewall ( en español le llamamos “corta fuegos” pero no me gusta como suena ). Realmente es un excelente equipo y con mucha flexibilidad, super recomendable para uso hogareño, hasta para una PyMe, sin llegar a comprar un equipo de primera linea ( Cisco, Juniper, Palo Alto, etc. ).

Sin más, vamos al grano, les quería dejar la configuración que estoy probando para bloquear las publicidades de YT, dado que últimamente se están excediendo con la cantidad y tuve que investigar como hacerlo, porque quería disfrutar del servicio sin interrupciones cada 2min. Es simple y contempla reglas de Firewall capa 3 y capa 7. Les dejo las lineas que tienen que poner por la terminal:

/ip firewall layer7-protocol add comment="" name=block-publicidad regexp="(doubleclick|google-analytics|googleadservices|googlesyndication)\.(net|com)"

/ip firewall filter add action=drop chain=forward comment="block-publicidad-yt" dst-port=80,443 layer7-protocol=block-publicidad protocol=tcp

/ip firewall filter add action=drop chain=forward comment="block-publicidad-yt-1" content="googleads.g.doubleclick.net" dst-port=80,443 protocol=tcp

/ip firewall filter add action=drop chain=forward comment="block-publicidad-yt-2" content=&ctier dst-port=80,443 protocol=tcp

La fuente: http://netscripting.blogspot.com/2017/02/bloqueo-de-publicidad-youtube-desde.html

Nota: Se tienen que asegurar que las reglas queden primeras, antes de las que tengan “permit”.

Espero que les sirva!